Monday, July 5, 2010

AIX Basics (Software installation and management)



Software and patch management

Software management includes the tasks of installing OS, Installing other programs, Installing TLs, APARs etc.
In an installable CD an OS comes as a number of file sets. These filesets once installed will have a combined OSlevel (version of OS eg: 5.1, 5.2, 5.3 etc) and a Technology level (Patch level eg: 5100-04 means TL4)
Command to check the os and TL level is
#oslevel –r
5300-07 ( means 5.3 TL 7)
Fileset is the smallest part of any installable software program or OS. The standard type of filesets AIX compatible are called bff (Backup file format) filesets. (Apart of bff format rpm packages and normal bin/cpio/tar packages are also installed in AIX like any other UNIX/Linux OS)
Eg: bos.tcp.client.5.2.0.35.bff
The filesets included(installed) in our system can be listed using command
#lslpp –l
The basic packaging structure is as shown below.



Applied state and Committed state of an installed fileset




AIX has a number of software states. When you are installing software for the first time, thesoftware will automatically install to a committed state. This means there is only one levelof that software product installed on your system.When you are installing a fix- or a maintenance- level upgrade to your system, You will be actually installing a higher version of a filesetor set of filesets. Here you have the option of installing the software either in the committed state or the applied state.
The applied state allows you to maintain two levels of the software on your system. Whensoftware is installed in the applied state, the older version is saved on the disk and isdeactivated while the newer version is installed and becomes the active version. The applied state gives you the opportunity to test the newer software before committing to its use. If it works as expected, then you can commit the software which will remove the oldversion from the disk. If the newer version is causing a problem, you can reject it which will remove the newer version and recommit the old version. For example if bos.net.nfs.client version 5.3.0.10 is in committed state in your system and you are installing a higher version of bos.net.nfs.client version 5.3.0.50 on top of it as part TL 5 you can apply the fileset and will keep a copy of the 5.3.0.10 in /usr and will be shown as committed when you do lslpp.
Now if your TL 5 has to be rejected and you want to go back to previous level you can reject all of your newer filesets which are applied.
#smitty maintain_software
Also when you are going to update next level say TL 6 or 7 you will need to commit the now applied filesets of TL 5 and the TL 1 version of filesets will be no more shown in lslpp output. (Their files will be permanently removed from /usr).

Technology Levels and Service Packs

ML (Maintenance Level): It is no more called ML but TL now (Technology level)

Periodic patches and enhancements will be released by IBM for each and every fileset which is part of the OS or subsystem.

Once higher version for all/most of the filesets in an OS level is released they are packaged into a single set called TL. (Eg: for os and TL level 5200-04 will be given an TL level set for 5200-05 after releasing all higher version filesets). A new AIX Technology Level is released roughly every six months or lesser than that.


To see the TL level


#oslevel –r


Service Packs
An AIX Service Pack (SP) is a bundle of PTFs released between Technology Levels. The PTFs/fixes address highly pervasive, critical, or security-related issues. To see the service pack level run

#oslevel -s

6100-02-01-0847 (Means AIX 6.1 TL 02 Service pack 01)


APAR

APAR(Advanced Program Analysis Report). APAR’s are reports generated by IBM Software support for specific problems with specific version of filesets/softwares. For these reports there will be a set of higher version filesets invented and will be downloadable from IBM fixcentral website. The process of downloading and installing these filesets is called applying an APAR. The APARs are given a number starting with IY or IZ normally (eg:IY85674) and the set of filesets for the solution changes depending on our servers oslevel and TL level. The installed APARs in our system can be listed using command
#instfix –i


E-fix

E-fixes are temporary fixes comes as a binary package (Not standard fileset) to provide interim solution to a problem reported by an APAR.

To install an e-fix

#emgr –p packagefilename

To list e-fixes installed

#emgr –P

To remove

#emgr –r efixname


Procedure to Download and install APAR

Once you have the APAR number to be installed first thing to do is to check if the APAR is already installed in your system using instfix command
(eg: #instfix -i grep IY72368)
It is also possible that the APAR number is not shown because you have a much higher level of TL already installed than the TL in which this APAR was included. In that case you need to check in the IBM fixcentral site with which TL the APAR is included. Installing APAR First of all we need to confirm if the APAR is already in your system and the system's current levels. If the APAR number is IZ64635 Run the following commands

#oslevel –r

#instfix –i grep IZ64635

#lslpp –l more

#installp -s (To see any if you have any applied filesets already)

Check for any broken filesets using

#lppchk –v

This command should not give any ouput in ideal case.

List all the applied filesets using

#installp –s

Then commit all applied filesets using

#installp –c all

Confirm with.

#installp –s



You can download all patches/microcodes/firmwares from IBM fixcentral website.




And select systemp, AIX, Your OS version, fix search respectively as below.




Provide APAR number to search




Click on Obtain this Fix






The service pack under which APAR is avilable will be listed. Click on the link to download.




Select the SP and click on continue





Select download option as ftp to ftp the filesets to your local laptop or server itself from internet. You can also select to download through Download director which is a java based tool if ftp is not available.



The site will give an ftp server address and fileset locations and size.






Create a directory or temporary filesystem according to the size of all filesets under /tmp Eg: /tmp/filesets. Connect to the ftp site and download these filesets to /tmp/filesets. Go to /tmp/filesets. #cd /tmp/filesets

Then run
#inutoc .

This will create an index file inside the directory called .toc Run command
#smitty installp

And select menu Update Installed Software to Latest Level (Update All). Select fileset installation files location as /tmp/filesets Select COMMIT as NO Select PREVIEW as YES Then press enter This will do an installation verification and will let you know if the installation would go smooth or not. We can search for “/error” in the smitty screen to find if the installation would create any clash or dependency issue. If there is no error we can go back to previous smitty screen using F3 and select PREVIEW as NO. This will do the actual installation.






OK message will appear after successful installation. Check with the following commands if the APAR is installed properly.


#instfix –i grep IZ64635

#installp –s

#lppchk –v


Do a BLV update to boot disks using bosboot command just in case.

#bosboot -ad /dev/hdisk0

#bosboot -ad /dev/hdisk1

If everything is fine reboot server once using
#shutdown –Fr

To download and install TLs /Service Packs
Downloading and Installing TL/SPs are same as downloading and installing APARs. Go to IBM Go to fixcentral website (http://www-933.ibm.com/support/fixcentral/)

And select systemp, AIX, Your OS version, fix pack respectively (instead of fix search) as below.



The next screen will contain all the TLs /SPs to be downloaded select the desired one and click continue to download.

To remove or reject file sets
#smitty maintain_software
From the menu select filesets to be removed and press enter.

RPM Packages
RPM packages are type of software packages used in Linux.

Originally standing for "Red Hat Package Manager", RPM now stands for "RPM Package Manager", a recursive acronym.
The installable files for programs comes as a single package file with .rpm extension
For (eg: Gzipver7.1.0.rpm is the installable file for gzip utility version 7.1)
To install an rpm package
#rpm –i installablepackagename
To list all rpm packages installed
#rpm –qa
To remove installed package
#rpm –e installedpackagename


-------------------------------------------------------------------------------------------------

No comments:

Post a Comment